追蹤
Gavin's Linux學習手札
關於部落格
原本這個 Blog 是用來記錄研究 Linux 的學習過程, 後來變成記錄生活與工作, 這個 Blog 裡的文章已成為我不可缺少的回憶。
  • 561161

    累積人氣

  • 154

    今日人氣

    1

    追蹤人氣

Cisco 配置 VLAN(轉載)

建立VLAN共需要兩個步驟,先是建VLAN,然後,再將相關介面指定至該VLAN。這個過程跟先劃分若干部門,然後,再將人員一一分配至各部門非常相似。

1.建VLAN
進入全域模式。
Switch# configure terminal
Switch(config)# vlan vlan_id
Switch(config-vlan)# name vlan-name
Switch(config-vlan)# end

Switch# show vlan [id | name] vlan_name

輸入VLAN ID,進入VLAN配置模式。VLAN ID的範圍為1~1001。其中,VLAN 1為系統預設VLAN,不能被建立,也不能被刪除。

name vlan-name(可選)為VLAN命名。如果不為VLAN命名,預設在VLAN ID前加0作為VLAN名稱。例如,VLAN0004是VLAN查看並檢驗VLAN配置 show vlan [id | name] vlan_name

2.將埠指定至VLAN
當已經在Switch上建了VLAN之後,接下來,就需要根據規劃將相對應的埠指定至該VLAN。

進入全局配置模式。
Switch# config terminal
Switch(config)# interface interface-id
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan vlan_id
Switch(config-if)# end
Switch# show interface interface-id
Switch# copy running-config startup-config

指定欲配置的介面後,將埠定義為VLAN成員模式(switchport mode access),並將介面添加至指定的VLAN。

【提示】  若欲將多個埠指定至某個VLAN,必須一一重複執行上述命令。或者採用range指令,一次將多個埠指定至同一VLAN。

3.清除介面配置
將指定介面恢復為預設值,即可清除該介面的所有配置,當然也包括VLAN設置。

Switch# config terminal
Switch(config)# default interface interface-id

4.刪除VLAN
使用no vlan vlan_id,可刪除指定的VALN。
進入全局配置模式。
Switch# configure terminal
Switch(config)# vlan vlan_id
Switch(config-vlan)# no vlan vlan_id
Switch(config-vlan)# end

檢查VLAN的改變。
Switch(config-vlan)# show vlan brief

 

【提示】  刪除VLAN後,所有指定至VLAN的埠將無法使用,直到將埠指定至新VLAN為止。

5.Trunk

圖片來源:http://dada147.blog.ccidnet.com/blog-htm-do-showone-type-blog-itemid-140201-uid-45077.html

 

Trunk須在兩端點都要設定。

 

Switch(config)# interface interface-id
Switch(config-if)# switchport mode  trunk
Switch(config-if)# switchport access vlan vlan_id

Switch(config-if)# switchport trunk allowed vlan {add | all | except | remove} vlan-list
配置Trunk上允許的VLAN。預設狀態下,Trunk埠允許所有VLAN的發送和介面傳輸。如需要,也可以將拒絕某些VLAN通過Trunk傳輸,將該VLAN限制與其他Switch互通,或者拒絕某些VLAN對敏感資料的查詢。需要注意的是,不能從Trunk中移除預設的VLAN1。使用add、all、except(除外)和remove關鍵字,可以定義允許在Trunk上傳輸的VLAN。VLAN列表既可以是一個VLAN,也可以是一個VLAN Group。當同時指定多個VLAN時,不要在“,”或“-” 間使用空格。

Switch(config-if)# switchport trunk native vlan vlan_id(選項)
這是設定Native vlan,平常不太需要設定。
 

當在Swtich上劃分有多個VLAN時,若欲借助一條鏈路實現與其他Switch上相同VLAN互通,就必須要使用Trunk。

範例:

Switch(config)# interface fa0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan remove 101-499
Switch(config-if)# switchport trunk allowed vlan add 250
Switch(config-if)# end
Switch# show interface fa0/1 switchport allowed-vlan
-------"1-100,250,500-1005"

也就是,只有 1-100,250,500-1005這些Vlan可以Trunk!



資料來源:
http://clif.pixnet.net/blog/post/23573069

相簿設定
標籤設定
相簿狀態